Skip to main content

Sometimes when I try to start my 2006 Nissan Altima SE, it makes a skipping sound like it isn't getting gas – and just keeps turning over, but won't fire up. It doesn't do it all the time, but when it does, it won't start until later. The car runs fine otherwise. Could it be something wrong with the fuel filter, lines to fuel or injectors? – William

The symptoms you describe suggest a familiar failing part used on many Nissans in both its four- and six-cylinder engines. The engine's crankshaft and camshaft sensors employed on your car are identical and problematic. The check-engine light is commonly (but not always) illuminated, indicating that a code P0340 and/or P0335 is stored in the powertrain control module (PCM). When present, these codes denote that one or both of the sensors are not communicating with the PCM. Surprisingly, the car may still run, albeit poorly with only one of these sensors operational, as the single functioning sensor will compensate for its failing sibling.

Symptoms of a faulty camshaft or crankshaft sensor are poor fuel economy, stalling, difficulty starting when hot and finally, a no-start condition.

Story continues below advertisement

When no other obvious tune-up or regular maintenance items are suspect, you should have your service provider take a look at these sensors and replace if even remotely questionable. Nissan has updated these parts and they are best sourced from the dealer and changed as a pair.

We've redesigned the Drive section – take a look

Report an error
Comments

The Globe invites you to share your views. Please stay on topic and be respectful to everyone. For more information on our commenting policies and how our community-based moderation works, please read our Community Guidelines and our Terms and Conditions.

We’ve made some technical updates to our commenting software. If you are experiencing any issues posting comments, simply log out and log back in.

Discussion loading… ✨